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Prerequisite

• Course 160
• Experience with SAP (http://go.sap.com/)
• Experience with AMR

Helps you with:

• Knowing how to analyse the SOAP logs
• Knowing how to analyse the Meter Read

Requests
• Understanding and troubleshooting the Meter

Model as mirrored from SAP to MDUS
• Understand when Meter Reading Requests are

honored

Once you are done with this Course, you should
be able to:
• Check why a meter reading is not updating to

SAP
• Check if a Meter definition exists properly on

MDUS
• Check if a Meter multiplier and data is

consistent
• Resend a Meter Reading to SAP
• Resend a SAP Message to MDUS
• Create Virtual MDUS reading
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HOWTO Analyse SOAP logs

1. General SOAP mode

All SOAP between SAP and MDUS, in

both directions, is in the form of

Messages that are sent. There are no

RPC kind of SOAP, where the same

SOAP message waits for a reply from

the implemented function on the server.

This makes the SOAP a lot more robust.

The SOAP messages can be envisaged

as a single XML structure, which is

essentially a single nested structure of

values.

2. How to choose message logs to view

Log in; Go to the Overview Screen

(Home); Select the relevant MDUS entity

(e.g. Production)

Go View → MDUS log
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This is a Selection Screen, where you

can choose which messages to see:

• The Start and End Date & Time is

self explanatory and should be

entered in the SQL format 

YYYY-MM-DD hh:mm:ss

• The MDUS Msg ID is a number unique

per message per PNPSCADA server

over all MDUS entities on that server.

A comma separated list may be

specified.

• The UUID is essentially a GUID

(unique in the universe) assigned in

SAP per message

• The ReferenceUUID is typically set

for messages that is sent as a Reply

or an Acknowledgement on another

message. It would then contain the

UUID of the original message

• The Function is the specific function

called by SAP or MDUS – easiest way

to know what to select here is to

first select a lot of messages, and
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then take the specific one you want

from the column in the report. This

loosely corresponds to the drop list

of functions in the MDUS Edit screen.

• Detail is the value of any field in the

message. If any of the values match

this value, the message would be

selected.

• Result Message is whether it was

successful or whether there was

some error. The easiest is also to run

the report first for all values, and

then specify the value as seen in the

appropriate column for the specific

kind of row required.

• Double UUIDs can happen, for

example in cases where you retry

the same message from SAP to

MDUS. If you want to avoid showing

the same retried message twice or

more times, you should check 'Do not

list Double UUIDs'.

When you have entered which messages
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you want to see, push the Submit button

to see the report.

This is the log of all XML messages sent

between SAP and MDUS.

SAP will for instance send messages to

'create' meters, and to 'create' registers

to read, and to create meter reading

requests.

MDUS will for instance send messages

back to send readings for previous

meter reading requests that was

created from SAP.

3. MDUS Log Report view

Here is shown the messages that was

sent and received, one line per

message, with various general fields.

You can view message details by

clicking the value under the UUID

column heading.

You can resent ALL the messages listed
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to MDUS as though it was just sent from

SAP, by clicking the link at the bottom of

the report. Of course that would only

apply to messages where the

DIRECTION column's value is 

'SAP->MDUS'

This can sometimes be handy if Meter

Entities was not properly created, or

meter register formats no properly

created, or meter readings not properly

created, for some reason. However it

should not be necessary under normal

circumstances.

4. MDUS Log Detail view

Here is shown all the Detail fields of the

XML message, with the nested field

name, and the value that was specified.

You can click the 'resend to myself' link

to re-submit the message to MDUS as

though it was just sent from SAP.
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HOWTO Analyse Meter Read

Requests

1. General Read Method

When SAP wants to read a meter

register, it creates a Meter Reading

document through one or more

messages, which are recorded in a

Meter Readings table in MDUS.

Typically, there would be multiple

registers read per meter per date. Each

one is a separate Meter Reading

Document.

When a meter is read in, MDUS will

check against the existing but

outstanding Meter Reading Documents

to see if there is any that can be

honored, and if there is, it will send

Messages of its own to SAP to report

the register reading.
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2. How to choose readings to view:

Log in; Go to the Overview Screen

(Home); Select the relevant MDUS entity

(e.g. Production)

Go View → MDUS reading docs

This is a Selection Screen, where you

can choose which reading docs to see:

• The Start and End Date & Time is

self explanatory and should be

entered in the SQL format 

YYYY-MM-DD hh:mm:ss

• The Meter Serial Number is the

number of the meter, or the SAP

device ID, of the meter read

• The Reading Document Number is

the unique number assigned by SAP

to a meter reading doc.

• The checkboxes are self explanatory

When you have entered which

messages you want to see, push the

Submit button to see the report.
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There is also a link at the bottom of

this selection screen, to download a

spreadsheet of all the defined MDUS

meters, with their SAP device IDs.

3. Meter Reading Document Report

This is a table view, with one row per

Meter Reading Document, of all the

readings that SAP has requested that

satisfies the Selection Criteria.

When a value is read, the SAP Value

column gets filled in, and also the Date

Fulfilled column. SAP is then supposed

to Acknowledge receipt of this reading.

If MDUS has tried 5 times to send a

value, it will give up. If you want MDUS

to try again, select 'rollback update'.
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HOWTO See Why Meter

Readings are not Updating
1. Did SAP ask for the reading from

MDUS?

Sometimes it happens that a meter has

not been correctly configured as an AMI

meter in SAP, and SAP doesn't even ask

MDUS for a reading.

Therefore go to the Meter Reading doc

report and search for the Meter Reading

document number as it exists in SAP. If

you do not find it, MDUS doesn't know

about it, and the meter has probably

been created as a non AMI meter. This

is why your readings are not

automatically updated.

You can also search for the Meter

Reading document number in the MDUS

log as a Detail value field. It is possible

that MDUS for some reason did not mark

the reading, so if you find it in the log
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but not the reading docs, you can try to

resend the message to MDUS.

However, if you also can't find it in the

log, and the SAP consultants swear the

readings were created ok, perhaps the

PI guys can resend the messages?

MDUS can not fabricate the reading

documents from scratch, it needs the

messages to be sent from SAP, and if it

has no record of them, they need to be

resent.

2. Did SAP 'create' the MDUS meter

record (associating the SAP device ID

with the actual entity on PNPSCADA)

When you download the spreadsheet on

the Meter Reading docs selection

screen, the Meter will not be listed

there if SAP did not create the Smart

meter record in MDUS by sending it the

appropriate messages. If you download

the csv and it is not there, this is why
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your readings are not updating.

3. Did SAP create the appropriate

Registers on the MDUS meter record.

If the row in the csv downloaded in step

2 has a 0 in the last column, no

registers has been defined by SAP for

this meter. That is why the readings are

not updated.

If, on the Meter Reading Document

report, the SAP Register column is a

long number with a lot of zeroes in

front, instead of an intelligible register

description, SAP has not defined the

same registers for this meter than it has

asked for in the reading document. That

is why the readings are not updated.

(The long number is the unique register

ID in SAP, and for resolvable registers,

you can see the long number as a tool

tip if you hover your pointer over the

register descriptor)

15/22



If the appropriate registers does not

exist, MDUS cannot fabricate them.

Those messages that creates the

registers needs to be resent to MDUS.

4. Does the meter entity exist on

MDUS?

Try to select the meter entity in the

Overview screen. Sometimes, a 13 digit

number would map to an 8 digit number,

e.g. 3201550644737 is the same meter

as 55064473. If you can't find the meter,

it has not been created in PNPSCADA

yet (typically done by the Technician),

and that is why you're not getting a

reading.

5. If you do find it, Has the meter been

read in?

If you do find it, but it is red in Overview

when you select it, the meter has never
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called in. That is why you're not getting

a reading.

Go to the Edit → Meter Details of the

meter. If the MAXDATE (last read up to

date) of the meter is less than the 'Date

asked for' on the meter reading doc

report, the reading does not update

because the meter has not been called

in.

If the meter is called in, but still does

not update, it might be that the profile is

read in but there are no TOU register

readings for the meter on a half hour

boundary yet. Go Edit → TOU Billing

Register Values. If there are no values

listed, that is why your readings does

not update.

You probably need to read the meter

after a Bill Reset event on the meter,

before the readings would be sent

through. 

(in some cases, where the reading does
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not advance at all, zero values can be

put in as initial values. Other algorithms

might also slow this down in future, e.g.

on season change, but that is still to be

determined)

6. It is possible that you have enabled

the Validation sub-system on your MDUS

entity, and that the meter has been

invalidated. If you go to the Meter

Validation screen and find your Meter

there, with an invalid from date of

before the reading date, that would be

why your meter is not updating.

Fix the fault on the meter or meter data,

and then Validate the meter. After that,

on subsequent reads, the readings

should go through.
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HOWTO See Why Meter

Readings are Wrong

Sometimes you will get queries about

some of the readings, that it looks

wrong, for various reasons e.g. that the

reading went in reverse, or that the

reading is too high.

When this happens, the first step is

always to view your Meter Event Log for

the month surrounding the reading, and

see if there were any Audit events.

There would usually be some events at

the time of the wrong reading that

should have alerted you to the wrong

data.

If you use the Validation sub system of

PNPSCADA, you can set such events to

Invalidate data on a meter, and in the

MDUS edit screen, you can set the

MDUS not to return such values.
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However, if this is not the case, go to

your Profile Graph adjoining the reading,

and see if you can see any obvious

disruptions to the normal usage pattern.

Although the full scope of

troubleshooting the underlaying problem

is beyond the scope of this course,

some examples of problems are that tt

could be that a VT fuse has blown, or

that there was some other thing on site

that went wrong. In some rare cases

there might even have been a data

corruption due to communication

corruption, or the Billing ratio might

also have been applied wrong: usually in

such a case, if the bad data is younger

than 3 months, you can 'fix' the data by

setting the MAXDATE back to before the

problem, and reading in the meter again.

If that doesn't work, you'll have to fix

the data manually, or call technical

PNPSCADA support.
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However, if the data looks right, and the

reading sent to SAP is still wrong, you

can try to do a Virtual MDUS Reading

(Tools → Create Virtual MDUS Reading)

This is not to be confused with a normal

Status 9 reading that is initiated from

SAP side. It is a reading initiated on

MDUS side, and it will create the meter

reading document on MDUS side, as

though SAP requested it, so that you

can go and look at it and attempt to find

the point at which the problem occurs.

If the SAP Value for the virtual reading

is correct, then the problem must have

happened somewhere beyond

PNPSCADA. However, if the SAP Value in

the Meter Read log of the Virtual

Reading is also wrong, then the problem

still exists on PNPSCADA.

This functionality can also be used as a

'dry run', after data was fixed, to make

sure the readings to SAP will go through
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fine if they are re-issued.
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