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Fault Finding
Fault Finding utilizes many screens.
•

Profile Graph

•

Communication Monitor

•

Problem Meter List

•

Meter Validation Screen

•

Phasor Graph

•

Meter Totals

Profile Graph

Consumption and Demand usage per half hour is graphed in the center. (Demand is only
shown if the tariff actually references it.)
To access the Profile Graph, select a Meter Account and go to View→Profile Graph.
Non-instantaneous events like power down, is shown as gray blocks behind the graphs.
The Legend is shown on the right.

2

Hover your mouse over a point in the graph to get the exact values measured at that point
shown on the left.
Below graph:
•

Current date selection

•

Date of cursor (mouse) position

•

Total (sum of) consumption for selected date range

•

Maximum demand along with power factor at maximum demand, time of maximum
demand

•

Load factor at both demand and consumption

Above graph:
•

Zoom in (first select a range by dragging on the graph).

•

Zoom out: Zooming out of a day, will show a week, out of a week will show a month,
etc.

•

Page Left/Right: Moves the range displayed on the graph one full page left/right.

•

Pan Left/Right: Moves the range displayed on the graph one tick left/right.

Switch between tariffs linked to this meter account using the tariff dropdown on the top right.
Switch between other meter accounts using the meter account dropdown on the top right (if
there are less than 20 meter accounts); or the previous/next links on the top right (if there are
more than 20 meter accounts)
Change to a different date range by clicking on the Choose Dates button bottom right.
Each half hour can be colored according to seasons and TOU (specified in the tariff).
Optionally the profile graph can be displayed below the Meter Account from the Edit->Meter
Account screen.

Possible Extrapolations
•

TOU optimizations
When the tariff is set up properly with TOU, you can easily see where you might be
using too much power during peak times.

•

Power Factor
Consumption can be compared against demand. (We use kW and not kWh for ease of
comparison). If power factor is bad, consumption and demand will differ a lot. A power
factor of 1 means demand and consumption will be equal.
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•

Meter bypass/tamper
The Profile Graph is an excellent tool for finding many problems with metered data.
If viewed over a month period, irregularities like a meter bypass can often easily be
detected, even for the untrained eye. A meter bypass will usually contain zeroes in
areas where consumption would be expected.

•

CT blown
A blown CT will mean the data will read on average 2 thirds of the usual readings. The
exact point of a blown CT can therefore often be seen where the consumption graph
suddenly drops to 2 thirds of the usual shape.

•

Lights/Aircons forgotten on during night time.
On nights when the consumption does not fall as low as other nights, aircons or lights
might have been left on.

•

Reversed CTs
Not the best place to pick up reverse CTs (Phasor Graphs are better for this); but if
they are reversed (and should not be); the graph should show zeroes.

•

Other Regular Problems
For example when a shop is closed and the manager switches off the power to the
shop at the breaker before the meter, the profile graph will show a regular power down
every night.

Shift usage
A calendar can be created for each shift, which in turn can be combined with the Meter
Account's Tariff (Under Edit->Meter Account). With this you can create a Profile Graph
showing only the usage for each shift and also instantaneously calculate the cost for each
shift using the optional Provisional Bill at the bottom.
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Problem Meter List

To get a list of all Meters with problems, go to Tools→Problem Meter List
Here you will get a list of all commissioned meters that have not read in up to today, in order
of up to where they have data.
Columns are:
•

Meter Serial
a link to that meter. From here you can go to Edit→Communication Monitor to
attempt to read that Meter manually

•

Read In Up To
Up to where the system has data for this meter

•

Meter Account Name
Name of the meter account linked to the meter, and if there are multiple Meter
Accounts linked to that meter, a comma separated list of Meter Account names.

•

Connection
The connection to that meter, such as the IP address or phone number of the
meter.

•

Problem
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This is the problem why there is no data for this meter
•

Outstanding
Data sets that are still to be acquired

•

Follow-up
A link to the Fault Log where a user can log faults against a meter, that is integrated
into many other screens and reports. From here you can assign a technician to a
meter and log any faults communicated by the technician.

Commissioned
If the Problem Meter List suddenly does not show any meters (and there should be meters), it
might be because one of your meters were marked as Commissioned under Edit→Meter
Details.
When no meters have the Commissioned Flag ticked, the system ignores the Commissioned
Flag. If one or more meters have it ticked, then only meters that are commissioned are shown
on the Problem Meter List.
You can get a list of which meters are commissioned and un-commissioned under
Reports→Various→Meters Where and Read.
Click toggle, to show both commissioned and uncommissioned meters.

Download
The download at the bottom will give a spreadsheet that contains many more columns if you
require more information.

Error Streak
In the case where a meter read is not even attempted by the system (i.e. View→Meter Read
Logs are empty), check current error streak under Edit->Advanced Meter Settings. When the
Meter fails a significant amount of times, the system will automatically try to read that meter
less often in an attempt to reduce load on the system.

Meters that did read in
To get a list of which meters did read in, go to Reports→Various→Meters Date

List of possible problems
Could not connect; Could not connect to the Etherpad, Your connection is not making contact
The system was unable to connect to the Communication Device (Modem/Etherpad). Check that the Comminication Device is setup
correctly. You can get more information in the first section of this wiki here
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Communication error
The system did connect to the Communication Device, and there was communication, but the communication dropped before the system
was done reading the Meter. This could be due to:
Bad Signal (very likely)
Not enough data on Prepaid SIM (likely)
Short on the communication line (unlikely). Typically with RS485, if the RX and TX line touches, everything that is transmitted is also
received, making it look like there is proper comms, but there is not.
Wrong COM port settings (unlikely). Communications using RS232 or 485 need to be programmed with a BAUD rate and Framing. Wrong
settings might result in garbled comms.
Communication error, no answer back
The system did connect to the Communication Device, but there was no comms. This could be due to:
Not enough data on Prepaid SIM (extremely likely)
Bad Signal (very likely)
Break in the communication line (unlikely)
Wrong COM port settings (unlikely). Communications using RS232 or 485 need to be programmed with a BAUD rate and Framing. Wrong
settings might result in no comms.
Connection reset: Happens when the Communication Device restarts.
CT discrepancy. Please fix first.: Typically the meter gets programmed with the CT ratio. The CT ratio also gets recorded in PNPSCADA
when you add the meter. The CT ratio in PNPSCADA should match the one in the meter.
Meter not Found
A connection was made to the Communication Device but the meter did not respond.
Accumulator not found
same as Meter not Found
Wrong Meter At Address
The meter serial number that was read from the meter, and the serial number that you entered into the system differs. For Elster
A1140/A1700 and AS230 the Multidrop Address in PNPSCADA and on the Meter need to match. You can use Elster's SMARTset to get the
correct multidrop address. Go to Edit->Meter Details to change the Multidrop Address in PNPSCADA.
Output Problem
You will need to contact SDG (010 003 1015) for this.
Invalid Meter Password
You can use the OEM software (SMARTset/MAP120/HexingView etc) to set the password on meters. You then need to enter that password
in Edit->Meter Details->Password so that PNPSCADA can log into the meter.
Could not find RTU at address; PLC meter not found; Could not find meter at address
The Communication Device is connected to the server, but the Meter is not answering back. See Communication Error, no answer back.
Spike
PNPSCADA calculates the maximum kW that can go through this meter with VTprim * Breaker Size * Number of Phases. So if you add a 3
phase meter with a 400/400 VT and a breaker size of 100A, which means 400*100*3=120000 or 120kW maximum. If a values is read from
the meter that is more than 10 times the maximum (in this case more than 1200kW) a spike is reported and the meter will not be read further.
Typically you need to enter the correct breaker size.
Still Waiting
An order has been logged to read the meter, but the underlying Head End System has not responded with the results
Not InUse
For Kamstrup Meters it means no concentrator has picked up the meter yet. The problem is between the meter and the Kamstrup server.
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Communication Monitor

The Communication Monitor allows the user to see the actual communication between the
server and the meter, and is an invaluable tool in finding problems with the acquisition of a
meter’s data. Also note that this screen works from a browser, even a phone browser and can
easily be used by a technician on site to troubleshoot a problem before leaving site.
You are presented with the Data Sets that you can acquire from the meter, such as Profile,
Totals, Events, Phasor and Instrumentation Profile.
You can tick which ones you want the system to read and then click on Start Read.
The system will then make a connection to the meter and read the relevant data sets.
Cyan [Blue-Green] text shows the server’s requests
Green text shows the meter’s response.
Communication channel is the modem’s IP address or phone number that is used to contact
the meter.
For modems with a fixed IP, the system will also ping the modem and show the results in the
top right as “Ping successful”.
There is a second monitor that shows debug information from the PNPSCADA driver that
often has additional information as to where a problem exists. You can access this monitor by
clicking on the link “debug mode”.
Untick the autoscroll link to pause the screen at the current position.
The Logs link shows all the read attempts for this meter.
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Meter Validation Screen

Meters log various events that can cause the data to become invalid for billing purposes, such
as a Tamper event or Reverse Run.
When the systems reads a meter and an invalidating event comes in, all the data for that
period is also marked as invalid.
The validation screen deals with validating data.
To access the Meter Validation Screen, go to Tools→Meter Validation Screen
The first screen is just a filter, but a blank submit will show all your meters.
Each meter with invalid data is shown per line.
First column is a quick link to the meter.
The problems column is a comma separated list of short codes of the events that caused the
data to become invalid.
You can click on this link to take you to the meter's events. (You can also access this screen
by selecting the meter and going to View→Meter Event Log). You can hover your mouse
over the short codes to get the full description in Meter Event Log.
You can control which events cause a meter's data to become invalid by going to Edit→Meter
Event Setup.
The From – To column is a quick link to the View→Profile Graph screen for the time that
there is invalid data.
The Last column contains 2 buttons to validate the data. The green one starts the validation
process. The yellow one does the same, but logs a message in the form of a Fault Log
against that meter (which you can access from Tools→Fault Log).
The validation process consists of 2 steps.
Step 1) Data audit:
There are 2 ways to calculate monthly consumption.
A) End Total minus Start Total
B) Sum of Half Hour Profile Values
Both ways should come to exactly the same value. If they don't, you have an audit error.
You can control the percentage threshold within which the profile and totals has to match up,
by changing the Validate within % input.
If a meter fails the audit error, it is shown as a red error message at the top of the table.
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You can resolve Audit Errors under Edit→Meter Totals.
Step 2) Mark all Data as Valid.
Typically you don't just want to mark all data as valid.
Often the quickest way to see if the data is correct, is to look at it in the Profile Graph (link in
the 4th column).

Phasor Graph
The first screen shows a table of phasors that have been read

Columns:
•

Time

•

Voltage and Currents over all 3 phases

•

Voltage and Current Angles over all 3 phases

•

kW (P)

If there are more than one page of phasors, you can navigate to the other pages by clicking
on next and previous
Click on a date to open the Phasor Graph for a specific date
The phasor graph shows:
3 thin lines in different color depicting voltage:
1. Red
2. Yellow (White)
3. Blue
3 thick lines in different color depicting current, corresponding to the thin voltage lines
The length of the thick lines indicate the relative load balance
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To the right of the graph is a table of actual values with columns for:
•

All 3 voltages and currents

•

All 3 volt and current angles

•

kW (P); kvar (Q) and kVA (S)

•

Power Factor (pf)

Examples

Example 1
This is what a typical 3 phase connection should look like.

Example 2
Look out for Phasor Graphs where the currents are small (less than 10A). If the current is
small you won’t necessarily get a good Phasor Graph. In this case this is not the problem.
If Red CT was moved to White Voltage,
White CT to Blue Voltage,
Blue CT to Red Voltage
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and all 3 CT's reversed,
you'll get a close to perfect Phasor Graph, which might be the problem in this case.

Example 3
Red CT should be reversed.
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Example 4
The phase rotation is the wrong way round, i.e. White and Blue Voltage and CT should be
swopped
Phase load balancing should be done at this site

Example 5
An example of a typical 3 wire connection
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Example 6
Not sure what is going on here, but everything seems to be wrong

Example 7
An example of a typical connection of properly working Power Factor Correction equipment
with correction derived from the Blue phase, overcompensating on White and
undercompensating on Red phase
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Example 8
An example of alternative Phase Rotation

Meter Totals

Under Edit→Meter Totals you can view, capture and delete totals, as well as audit meter
data.
Some totals are grayed out. These are called check totals. They are totals that are not on the
half hour and thus cannot be used in conjunction with the half hour profile values.
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To Capture a New Total
Click on Enter Manual Reading top center.
A new row will show at the top of the table.
You can enter a date in the first column.
Active Import is the main consumption where you would typically capture a Total.
Remember to click the Set button in the last column.
Manually Captured Totals have a status of 9.
When capturing a new total, half hour profile values are also generated (interpolated) to add
up to the difference between this total and the previous.

To Delete A Total
Click on the delete link in the last column.
If there is no delete link, it is because the total was read from the meter (status 3) and might
re-appear next time the system reads the meter.
If you still want to delete that total, you can Capture a Manual Total over this one (same date
and time). That should change the status to 9 and give you an option to delete.

Auditing
Auditing works on the principal that there are 2 ways to calculate monthly consumption:
A) End Total minus Start Total
B) Sum of Half Hour Profile Values
Both ways should come to exactly the same value. If they don't, you have an audit error.
For each consecutive total shown, the system also sums the half hour profile values between
the two totals and compares it with difference in the totals.
Depending on how the difference in totals compares to the sum of profile, the totals will be
highlighted according to the legend at the bottom of the table.
Audit errors can happen for various reasons:
1) CT reprogram (likely)
2) Meter data scaling (likely). Under Tools->Modify Readings
3) Meter Faulty (unlikely)
When encountering an audit error, you need to decide which are more accurate (or
necessary). The Profile or the Totals.
If the meter is on a demand tariff, the profile is typically invaluable.
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In the case of CT reprogram or Data Scaling, the Profile values will typically be more
accurate.
In the case of manual meter readings, the Totals are typically more accurate.
The main screen to deal with audit errors is Edit→Meter Total

Meter Total
When you have decided which one to keep, you can make the other one to match up. The
match up process is always done from last readings to first readings. This is because the
meter is currently on a specific total so the next total read from the meter will go on from the
last one.
The check totals cannot be made to match up, so the easiest is just to delete them. Click on
hide check totals, then delete check totals.
In the case of profile being right, you can recalculate totals:
Clicking on recalculate (last column) will take the next total and subtract the in between profile
values to get to what this total should have been.
In the case of totals being right, you can re-interpolate profile:
Click on “reinterpolate” link (last column) to generate profile between this total and the next
that will add up to the same value as the difference of the totals. Note that interpolation will
work only for consumption, and not for demand.

Meter Audit

Another screen to resolve audit errors is under Tools→Meter Audit
This screen can only audit one register at a time.
Start off by choosing the start and end date and the register you want to audit.
Then click Change.
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One row will be shown for each total between these two dates (disregarding check totals).
Columns:
1. Date of total
2. Register name e.g. E1
This shows the total for that date
3. Difference From Previous
Showing the difference in the total and the previous total
4. Sum [Register Profile Name] e.g. Sum P1
Showing the sum of the profile values between this total and the previous total.
This should be the same as the previous column.
If it is not, you have an audit error.
The following 4 are options that you have, to fix a total or profile, only one of which can be
chosen at a time
5. Delete Total
Will delete this total on submission
6. Recalculate Total
Will recalculate this total, taking a later total and subtracting the profile in between this
total and the later total.
7. Recalculate Total (Forward)
Will recalculate this total, taking an earlier total and adding the profile in between.
Typically one should give preference to a later total, as this is closer to what the meter
is currently on.
8. Interpolate Profile
This will generate profile between these two totals that add up to the difference
between the totals. This option should not be use on meters with TOU or Demand.
9. Time Span
The time span between the two totals
10. Samples in Profile
The number of samples between the two totals in the profile vs how many there should
have been.
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TOU and Billing Registers
Some meters can be programmed with special registers that only add up during TOU times,
or registers that log, for example the Demand.
These Billing Registers can be used by PNPSCADA to calculate a bill, rather than using the
raw profile values.
In order to get the PNPSCADA to use the Billing Registers, a couple of things need to be in
place:
•

The TOU calendar should be programmed into the meter
This step is done with the meter’s OEM software

•

a copy of the Calendar needs to exist on PNPSCADA
A calendar can be added under File→New→Calendar. You can share a calendar
between meters with the same TOU setup

•

The meter on PNPSCADA needs to be linked to the PNPSCADA Calendar
This is done by selecting the Meter and going to Edit→Advanced Meter Settings and
choosing the correct calendar there.

•

The PNPSCADA Calendar should be set up with a mapping that maps each Rate
Register in the PNPSCADA to the code in the meter.

This is done by selecting the Calendar and going to Edit→Calendar Register.
Here you can have a line for each rate register in the Calendar and under the “Meter
Register Descriptor” column, be sure to add the correct code that a meter calls the rate
register.
e.g. You can have a line that takes the High Demand Peak Rate Register, and maps
that to a meter’s register with code 1.1.1.8.1.255.
In order to see all the available codes that a meter exports and their corresponding
values, you can go to View→Meter Registers (after the meter has been read the first
time) to see the values before processing.
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Or go to Edit→TOU Billing Register Values, to see the values after processing

•

For SAP, the Billing Register can be mapped to the corresponding SAP register also
under Edit→Calendar Register and in the Billing Register Descriptor.
e.g. For the Rate Register High Demand Peak, you can map to the SAP Register
“PEAK”

•

There should be totals for both the start and end billing reset dates. You can specify
the billing reset dates at the top of the Edit→Calendar Register screen
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